Partial outage related to CLE course pages
Incident Report for Quimbee
Resolved
This incident has been resolved.
Posted Jan 30, 2023 - 13:00 EST
Investigating
We are currently investigating this issue.
Posted Jan 30, 2023 - 10:43 EST
This incident affected: www.quimbee.com.